3dscapture.com

Support Forum
It is currently Sat Nov 18, 2017 11:18 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Motherboard Test Points
PostPosted: Sat Sep 09, 2017 6:59 pm 
Offline

Joined: Sat Sep 09, 2017 5:48 pm
Posts: 1
Hi. I am modifying a 2DS to allow it to interact with an Arduino as part of a school project. I am not particularly new to modding, but this is the only place that I've been able to find that has provided a detailed mapping of the pins that I need. I know how to operate the basic pins - the d-pad, ABXY, the shoulders, and so on. The only pins that I don't fully understand are TP3, TP68, TP69, and TP255.

Based on locations and application with the controller mod, I can guess that TP3 has something to do with the power switch, and that it provides power for the Controller Mod and its controller, and TP68 and TP69 are likely for the circle pad, although I would imagine that the circle pad uses analog to communicate, while all that's needed to 'press' the other buttons is to take the corresponding pin to ground.

What I don't know, however, is the purpose of TP255. It appears to connect to pin 3 on the Contoller Mod, but only one type controller uses it, so I'm not sure how important it actually is for me to bring it out. I am curious if anyone knows where I might be able to discriptions of what these pins are used for and how they work, or who I might be able to contact in order to figure this information out. I understand that the datasheets probably aren't public, so I'd like to ask for help if anybody does know.

I have already made the connections using enamel coated wire that is fed around to the back and attached to pins that have been fitted through the casing. However, when I reassemble the DS, the power will only turn on if the two broader connectors that control the screens are disconnected. Leaving them disconnected allows the power to the system, but only the backlights and audio will turn on. When I properly clamp them down, however, I am unable to turn the system on, as though it is somehow grounding itself. I know that it's not an issue with the screens themselves, because I swapped the board with another system that I used to use for testing, and found the same result with the board that I'm working with, while my test board started up properly.

I'm not sure what the issue might be in this case. I am very careful with the clamps and the board in general, and I use static protection. My only thought is that, if I didn't damage the board itself, then either TP3 or TP255 are somehow interfering through the connections that I've made, which is part of the reason why I wanted to know what, exactly, they're used for.

Any help with either of these matters would be greatly appreciated.


Report this post
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group Color scheme by ColorizeIt!